Einloggen um die Werbung zu entfernen!

AR Drone 2.2 startet nicht trotz uploadet at2so.arm

Mehr Reichweite für die AR.Drone mit dem MiruMod. Auch bekannt unter: MacGyver, RC Kit, RC Umbau
Antworten
KoS
Eintagsfliege(r)
Beiträge: 3
Registriert: 9. Jun 2014 09:49
Copter: AR.Drone 2
Hat sich bedankt: 0
Danksagung erhalten: 0

AR Drone 2.2 startet nicht trotz uploadet at2so.arm

Beitrag von KoS » 9. Jun 2014 10:12

Hallo,

auf Basis der Anleitungen des MiruMod habe ich diesen für die AR Drone HW 2.2 selbst gebaut (also Arduino Nano + LLC). Nun habe ich folgendes Problem, wenn ich versuche mit geflashter DRS021 zu booten, erhalte ich nach einiger Zeit die 1+1 Blinks und nichts geht weiter, auf der Drone fehlen die Dateien. Im Hyperterminal sehe ich auch das er versucht stty zu setzenm aber das klappt wohl nicht. Ich sehe auch keine Bootmeldungen von der Drone.
Mit DRS019 komme ich etwas weiter, da wird die Datei hochgeladen und ausgeführt, allerdings bleibt die LED auf dauerleuchte. Das die Datei existiert und ausgeführt wird, konnte ich per Telnet verifiziert. Reagieren auf die Fernbedienung und damit abheben tut die Drone aber nicht.

Mir ist jedoch aufgefallen, das ich mit dem DRS019 etsprechenden Output von der Drone im Hyperterminal bekomme, aber statt sauberen Bootmessages erhallte ich wildes Binäres wirrwarr und sehe nur im klartext das gunzip und chmod ausgeführt wurde (viel mehr als bei DRS021). Ich vermute mal dass genau daran die weitere Verbindung scheitert.

Es stellt sich für mich jetzt die Fragen,
a) warum funktioniert DRS021 nicht bzw. bekomme dort keine Rückmeldung von vom Serialport
b) woran kann es liegen das ich keine saubere Bootmessage bekomme?

Anbei ein Screen der letzten Ausgabe, davor kommt natürlich noch wesentlich mehr.

Viele Grüße
KoS
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

KoS
Eintagsfliege(r)
Beiträge: 3
Registriert: 9. Jun 2014 09:49
Copter: AR.Drone 2
Hat sich bedankt: 0
Danksagung erhalten: 0

Re: AR Drone 2.2 startet nicht trotz uploadet at2so.arm

Beitrag von KoS » 20. Jul 2014 13:29

Leider bisher immer noch keine Lösung.
Ich vermute mal das es möglicherweise an der Bautrate liegt, aber ich bin leider nicht so tief in dem Code als das ich wüsste was wo zu ändern ist.
Es würde mir ja reichen wenn ich die Drone schon mit DRS019 starten könnte. Die at2so.arm wird ja auf die Drone geladen und läuft auch, aber der Arduino bekommt wohl keine vernünftige Rückmeldung (daher vermutung Bautrate).

Wäre super wenn mir jemand weiterhelfen könnte!

laterne
Propellerauswuchter
Beiträge: 260
Registriert: 17. Aug 2013 14:23
Copter: AR.Drone 2
Hat sich bedankt: 0
Danksagung erhalten: 0
Kontaktdaten:

Re: AR Drone 2.2 startet nicht trotz uploadet at2so.arm

Beitrag von laterne » 20. Jul 2014 17:17

auch in Hyperterminal CTRL + B gedrückt ?
also für solche speziellen Sachen wende Dich am besten an den Entwickler selbst --> http://www.rcgroups.com/forums/showthread.php?t=1420951

Gruss
http://www.snoopydog.de/ar.drone
RC-Mod mit Funke im Eigenbau unter 100 €

KoS
Eintagsfliege(r)
Beiträge: 3
Registriert: 9. Jun 2014 09:49
Copter: AR.Drone 2
Hat sich bedankt: 0
Danksagung erhalten: 0

Re: AR Drone 2.2 startet nicht trotz uploadet at2so.arm

Beitrag von KoS » 20. Jul 2014 17:24

Hallo laterne,

ja, versucht habe ich das schon, da bekomm ich dann aber nur die im Scroll-Down Rückmeldung vom Arduino über die positionen der Sticks, das funktioniert auch soweit, aber keine Rückmeldung von der Drone.

Dann muss ich mich wohl doch mal aus meiner Komfort-Zone bewegen und im englischen Forum posten. Danke!

Antworten