Seite 3 von 4

Re: NEW XR-4Drone v2 Mirumod

Verfasst: 13. Okt 2013 19:17
von Angeal
Unter Windows 8 benötigt man z.B. keinen Treiber bzw. Er installiert sich automatisch. Aber für andere Versionen könnte es hilfreich sein.

Re: NEW XR-4Drone v2 Mirumod

Verfasst: 14. Okt 2013 15:09
von Disman
Eigentlich wollte ich jetzt die große Mühe eurerseits mit einem Bildschirmfoto belohnen. Doch das bleibt zunächst Wunschdenken. Ich bekomme einfach den MiruPCB nicht zum Laufen. Die geposteten Treiber funzen nicht. Jedenfalls kann ich mit Rechtsklick "Installieren" keinen zum arbeiten bewegen. Ich benutze jedoch eine 64-Bit Version von Windows 7. Im Gerätemanager wird der verbundene Arduino micro nicht angezeigt, kann da also auch keine Treiber aktualisieren. :?

Re: NEW XR-4Drone v2 Mirumod

Verfasst: 14. Okt 2013 15:21
von Angeal
Er wird auch nicht direkt im Gerätemanager angezeigt. Gibts denn das typische "Gerät erkannt" Geräusch beim anschließen?

Re: NEW XR-4Drone v2 Mirumod

Verfasst: 14. Okt 2013 16:02
von Disman
Nein, da tut sich gar nichts.

Re: NEW XR-4Drone v2 Mirumod

Verfasst: 16. Okt 2013 17:03
von Angeal
Ich habe eben ein Problem festgestellt.

Wenn ich die Drohne starte im Modus Normal (Config 3) und dann einige Zeit fliege dann lässt sie sich nicht mehr bzw. zu spät landen.

Wenn ich die Landung einleite (Gear 0) dann scheint die Drohne zwar den Landebefehl zu erhalten (Motor LED blinken grün) aber sie landet einfach nicht und nimmt teilweise auch gar keine Befehle mehr entgegen.

In den anderen Modi konnte ich das Problem nicht nachvollziehen.

Einmal ist die Drohne auch direkt nach dem Start so schnell nach oben geflogen, obwohl ich Throttle quasi auch der Mittelstellung hatte. Allgemein habe ich irgendwie das Problem das die Drohne ab und an einfach nicht auf Befehle der Fernbedienung (DX6i) reagiert.

Re: NEW XR-4Drone v2 Mirumod

Verfasst: 17. Okt 2013 15:28
von Disman
Was mich interessiert, kann ich den Setup-Mode irgendwie erzwingen? Woran liegt es, dass ich nach dem Anstecken des Mod, keine Hardware-erkannt-Reaktion des Betriebssystems bekomme? Einen Hammer hätte ich gleich hier in der Schublade oO.

Re: NEW XR-4Drone v2 Mirumod

Verfasst: 17. Okt 2013 16:59
von Angeal
Beim neuen MiruMod ist dieser Setup Mode ohne Jumper quasi immer da.
Warum dir die Hardware nicht angezeigt wird kann ich dir nicht sagen.

Eventuell mal einen anderen USB Slot nutzen, ein anderes Kabel oder einen anderen Computer.

Re: NEW XR-4Drone v2 Mirumod

Verfasst: 21. Okt 2013 16:40
von Disman
Du hast den Nagel auf den Kopf getroffen. Ein anderes Kabel ist die Lösung. Dabei habe ich schon 2 probiert. Woher die aber waren, kann ich nicht mehr zuordnen. Habe jedenfalls gelesen, dass zur Zeit durch verschiedene Firmen angepasste Standards genutzt werden. Halt nur 2 Leiter angeschlossen und solche Späße. Jetzt zu den versprochenen Bildern:
bild1.jpg

Re: NEW XR-4Drone v2 Mirumod

Verfasst: 22. Okt 2013 12:41
von Disman
Habe mit HyperTerminal noch einmal ausgelesen:
TX_OFF_ON.jpg
Im MiruMod Manual sieht das aber so aus:
XR-4Drone_Manual1.jpg
Hat jemand eine Idee? Ich wäre auch für eine Lösung dankbar, wenn es sein muss. :lol:

Re: NEW XR-4Drone v2 Mirumod

Verfasst: 25. Okt 2013 15:00
von Disman
Habe grad meine erste Flugstunde mit dem Miru hinter mir. Einfach nur fantastisch. 8-) Auf diesem Weg vielen Dank an Angeal, der mir per PN tapfer zur Seite stand. Ich fasse noch einmal zusammen:
Ich habe tatsächlich einen Mirumod bekommen, der nicht "sauber" programmiert war. Erst das Aufspielen eines angepassten Sketches (http://mirumod.tk) löste mein Problem mit der unmöglichen Belegung meiner Funke (witzel mode 5). Zu allem Ungemach besaß ich aber nur ein Micro-USB-Kabel, welches die Datenkanäle nicht kontaktiert hatte. Das hat viel Ärger bereitet, bis ich Hyperterminal und Arduino IDE bedienen konnte. (muss man nämlich erst einmal drauf kommen) Ähnlich viel Geduld beim Meistern eurer Herausforderungen.

Disman :D